Back to overview
Resolved

Intermittent web application disruptions

Jun 30, 2026 at 9:02am UTC
Affected services
Web UI

Resolved
Jun 30, 2026 at 9:02am UTC

We are aware that nexuserp.dev has had brief, intermittent disruptions over the past few days. Each one is caused by a request-triggered fault deep in the web application's request-handling layer that makes the app briefly stop responding until it automatically restarts. Our auto-recovery brings it back within about a minute each time, so individual disruptions are short.

We have isolated where the fault occurs and are rolling out two improvements: (1) the application will recover in seconds rather than ~a minute when it happens, and (2) additional diagnostics that capture the exact request which triggers it, so we can eliminate the underlying cause. We will post further updates as the fix is confirmed.

No customer data is affected, and background processing, the database, and messaging are unaffected throughout.